@prefix bibo: <http://purl.org/ontology/bibo/> .
@prefix dc: <http://purl.org/dc/elements/1.1/> .
@prefix dcterms: <http://purl.org/dc/terms/> .
@prefix deo: <http://purl.org/spar/deo/> .
@prefix foaf: <http://xmlns.com/foaf/0.1/> .
@prefix orb: <http://purl.org/orb/1.0/> .
@prefix owl: <http://www.w3.org/2002/07/owl#> .
@prefix rdf: <http://www.w3.org/1999/02/22-rdf-syntax-ns#> .
@prefix rdfs: <http://www.w3.org/2000/01/rdf-schema#> .
@prefix reg: <http://purl.org/linked-data/registry#> .
@prefix schema: <https://schema.org/> .
@prefix sro: <http://salt.semanticauthoring.org/ontologies/sro#> .
@prefix vann: <http://purl.org/vocab/vann/> .
@prefix vs: <http://www.w3.org/2003/06/sw-vocab-status/ns#> .
@prefix xsd: <http://www.w3.org/2001/XMLSchema#> .

dc:creator a owl:AnnotationProperty .

dc:date a owl:AnnotationProperty .

dc:description a owl:AnnotationProperty .

dc:rights a owl:AnnotationProperty .

dc:title a owl:AnnotationProperty .

<http://purl.org/spar/deo> a owl:Ontology ;
    rdfs:label "Discourse Elements Ontology (DEO)"@en ;
    dc:contributor "Sebastian Barzaghi (https://orcid.org/0000-0002-0799-1527)"^^xsd:string ;
    dc:creator "David Shotton (https://orcid.org/0000-0001-5506-523X)"^^xsd:string,
        "Silvio Peroni (https://orcid.org/0000-0003-0530-4305)"^^xsd:string ;
    dc:date "2026-08-14" ;
    dc:description """
The **_Discourse Elements Ontology (DEO)_** is an ontology written in OWL 2 DL that provides a structured vocabulary for rhetorical elements within documents (e.g. Introduction, Discussion, Acknowledgements), enabling these to be described in RDF.
The main class of this ontology is `deo:DiscourseElement`, which describes all those elements of a document that carry out a rhetorical function. 
All the remaining rhetorical behaviours are modelled as subclasses of this class. 

![The main classes in DEO.](deo.png)

Some of the DEO entities are aligned with some of the rhetorical blocks from the [SALT Rhetorical Ontology](http://lov.okfn.org/dataset/lov/vocabs/sro) and the [Ontology of Rhetorical Blocks (ORB)](http://www.w3.org/2001/sw/hcls/notes/orb/), and extends them by introducing additional classes, including the following:
* `deo:Reference`, which specifies a connection either to a specific part of the document or to another publication. 
In written text, numbered superscripts standing for footnotes, items in a table of contents, and items describing entities in a reference section, can be modelled as individuals of this class;
* `deo:BibliographicReference`, a subclass of the `deo:Reference` that describes references to other publications, such as journal articles, books, book chapters or websites; such references are often contained in a footnote or a bibliographic reference list;
* `deo:Caption`, that defines the text accompanying another item (e.g., the legend describing a picture);
* `deo:Introduction`, the initial description that states the purpose and goals of the subsequent text;
* `deo:Materials`, that documents the specific materials used in the described work;
* `deo:Methods`, that documents the methods used in the work (may be combined with a description of the materials used);
* `deo:Results`, that describes a report of the specific findings of an investigation;
* `deo:RelatedWork`, that describes a critical review of current knowledge by specific reference to other relevant works, both in terms of substantive findings and theoretical and methodological contributions within a domain of study;
* `deo:FutureWork`, a proposal for new investigations to be undertaken in order to continue and advance the work described in the publication.

Note that it is still possible to apply two different rhetorical characterisations to the same block of text. 
For instance, in journal articles it is common to have a section entitled "Materials and Methods", which can be characterised rhetorically by using both the classes `deo:Methods` and `deo:Materials`.

DEO is imported in [DoCO](http://purl.org/spar/doco), which is an OWL 2 DL ontology that provides a general-purpose structured vocabulary of document elements.

## Examples of use

In the following subsections, we introduce some examples to showcase how to use DEO. 

The prefixes that are used in all the examples provided below are defined as follows:

    @prefix deo: <http://purl.org/spar/deo/> .
    @prefix doco: <http://purl.org/spar/doco/> .
    @prefix c4o: <http://purl.org/spar/c4o/> .
    @prefix cito: <http://purl.org/spar/cito/> .
    @prefix schema: <http://schema.org/> .
    @prefix dcterms: <http://purl.org/dc/terms/> .
    @prefix xsd: <http://www.w3.org/2001/XMLSchema#> .

### Tagging paper blocks with rhetoric entities 

DEO can be used in order to characterise the major rhetorical elements of a research article, such as the introduction part, the evaluation section, the conclusions and so on.

    <#paper>
        dcterms:title "Semantic Structuring of Scholarly Articles in HTML5" ;
        dcterms:hasPart 
            <#sec_abstract> ,
            <#sec_intro> ,
            <#sec_methods> ,
            <#sec_eval> ,
            <#sec_concl> .

    <#sec_abstract> a doco:Section, deo:Abstract ;
        dcterms:title "Abstract" ;
        c4o:hasContent "This paper introduces an end-to-end framework for embedding fine-grained discourse elements..."@en .

    <#sec_intro> a doco:Section, deo:Introduction ;
        dcterms:title "1. Introduction" ;
        dcterms:hasPart <#p_problem_statement> .

    <#p_problem_statement> a doco:Paragraph, deo:ProblemStatement ;
        c4o:hasContent "Current semantic publishing pipelines often fail to preserve structural dependencies between discourse units."@en .

    <#sec_methods> a doco:Section, deo:Methods ;
        dcterms:title "2. System Architecture & Methods" ;
        dcterms:hasPart <#p_algorithm> , <#sec_materials> .

    <#p_algorithm> a doco:Paragraph, deo:Model ;
        c4o:hasContent "We formulate discourse mapping as an acyclic graph traversal over the DOM tree." ;
        cito:extends <http://dx.doi.org/10.1007/978-3-540-89704-0_17> .

    <#sec_materials> a doco:Section, deo:Materials ;
        dcterms:title "2.1 Benchmark Dataset" ;
        c4o:hasContent "Evaluation uses a corpus of 1,200 open-access biomedical and computer science preprints." .

    <#sec_eval> a doco:Section, deo:Evaluation, deo:Results ;
        dcterms:title "3. Experimental Results" ;
        c4o:hasContent "The proposed extractor achieves an F1-score of 94.2% on heterogeneous layouts." .

    <#sec_concl> a doco:Section, deo:Conclusion ;
        dcterms:title "4. Conclusion & Outlook" ;
        dcterms:hasPart <#bloc_future_work> .

    <#bloc_future_work> a doco:Paragraph, deo:FutureWork ;
        c4o:hasContent "Future research will integrate large multimodal models for direct visual-layout grounding." .

## Competency Questions

DEO can be used for answering several questions related to rethorical elements used in documents.
In the following subsections, some of them are introduced together with their respective SPARQL queries. 

The prefixes that are used in all the SPARQL queries provided below are defined as follows:

    PREFIX deo: <http://purl.org/spar/deo/>
    PREFIX cito: <http://purl.org/spar/cito/>
    PREFIX c4o: <http://purl.org/spar/c4o/>
    PREFIX doco: <http://purl.org/spar/doco/>
    PREFIX dcterms: <http://purl.org/dc/terms/>

### CQ1

What are the structural sections of a paper and their specific discourse roles?

    SELECT ?paper ?section ?title ?role
    WHERE {
        ?paper dcterms:hasPart ?section .
        ?section a doco:Section, ?role .
        FILTER(?role != doco:Section)
        OPTIONAL { ?section dcterms:title ?title . }
    }

### CQ2

Which internal discourse models or components extend external works?

    SELECT ?element ?citedWork ?content
    WHERE {
        ?element a deo:Model ;
            cito:extends ?citedWork .
        OPTIONAL { ?element c4o:hasContent ?content . }
    }

### CQ3

What is the future work outlined in the conclusion of a document?

    SELECT ?conclusionSection ?futureWorkElement ?futureWorkContent
    WHERE {
    ?conclusionSection a deo:Conclusion ;
        dcterms:hasPart ?futureWorkElement .
    ?futureWorkElement a deo:FutureWork ;
        c4o:hasContent ?futureWorkContent .
    }

"""@en ;
    dc:title "The Discourse Elements Ontology (DEO)"@en ;
    dcterms:bibliographicCitation "Constantin, A., Peroni, S., Pettifer, S., Shotton, D., Vitali, F. (2016). The Document Components Ontology (DoCO). In Semantic Web – Interoperability, Usability, Applicability, 7 (2): 167-181. Amsterdam, The Netherlands: IOS Press. https://doi.org/10.3233/SW-150177" ;
    dcterms:created "2011-05-05" ;
    dcterms:issued "2015-07-03" ;
    dcterms:license <http://creativecommons.org/licenses/by/4.0/> ;
    dcterms:modified "2026-08-14" ;
    dcterms:publisher <https://ror.org/00wb4mk85> ;
    dcterms:source <https://github.com/SPAROntologies/deo/blob/master/docs/cq.md> ;
    bibo:doi "https://doi.org/10.25504/FAIRsharing.39fd58" ;
    bibo:status <http://purl.org/ontology/bibo/status/published> ;
    vann:changes """
* **v1.2.0**: Added new documentation, including annotation properties (e.g., `bibo:doi`, `schema:codeRepository`, etc.), term properties (e.g., `vann:example`, `vs:term_status`, etc.), exemplary competency questions with their respective SPARQL queries, and a Grafoo diagram.
    """@en ;
    vann:preferredNamespacePrefix "deo"@en ;
    vann:preferredNamespaceUri "http://purl.org/spar/deo"@en ;
    rdfs:seeAlso <http://www.sparontologies.net/ontologies/deo> ;
    owl:backwardCompatibleWith deo:2015-07-03 ;
    owl:priorVersion deo:2015-07-03 ;
    owl:versionIRI deo:2026-08-14 ;
    owl:versionInfo "1.2.0"^^xsd:string ;
    foaf:logo <https://github.com/SPAROntologies/deo/blob/master/spar.png> ;
    schema:codeRepository <https://github.com/SPAROntologies/deo> ;
    schema:image <https://github.com/SPAROntologies/deo/blob/master/docs/current/deo.png> ;
    schema:includedInDataCatalog <https://fairsharing.org/> ;
    schema:keywords "bibliometrics"@en,
        "rethorical elements"@en,
        "scholarly publishing"@en,
        "scientometrics"@en,
        "semantic publishing"@en .

deo:Acknowledgements a owl:Class ;
    rdfs:label "acknowledgements"@en ;
    vann:example """
    :my-paper 
        dcterms:hasPart :my-acknowledgements .

    :my-acknowledgements a deo:Acknowledgements .
    """ ;
    rdfs:comment "Usually part of the preface, or a separate section in its own right, often as part of the back matter, it acknowledges those, including funding agencies, who contributed to the undertaking of a research project described in a publication, or to the creation of the work in some way. In scientific articles, the acknowledgements are usually placed as a separated section immediately following the Discussion or Conclusions."@en ;
    rdfs:isDefinedBy deo: ;
    rdfs:subClassOf deo:DiscourseElement ;
    vs:term_status reg:statusStable .

deo:AuthorContribution a owl:Class ;
    rdfs:label "author contribution"@en ;
    vann:example """
    :my-paper 
        dcterms:hasPart :my-author-contribution .

    :my-author-contribution a deo:AuthorContribution .
    """ ;
    rdfs:comment "A description of the roles played by an author in the publication."@en ;
    rdfs:isDefinedBy deo: ;
    rdfs:subClassOf deo:DiscourseElement ;
    vs:term_status reg:statusStable .

deo:Background a owl:Class ;
    rdfs:label "background" ;
    vann:example """
    :my-paper 
        dcterms:hasPart :my-background .

    :my-background a deo:Background .
    """ ;
    rdfs:comment "Presentation of information that is essential for understanding the situation or problem that is the subject of the publication. In a journal article, the background is usually part of the Introduction, but may be present as separated section." ;
    rdfs:isDefinedBy deo: ;
    rdfs:subClassOf deo:DiscourseElement ;
    owl:equivalentClass sro:Background ;
    vs:term_status reg:statusStable .

deo:BibliographicReference a owl:Class ;
    rdfs:label "bibliographic reference"@en ;
    vann:example """
    :my-paper 
        dcterms:hasPart :my-bibliographic-reference .

    :my-bibliographic-reference a deo:BibliographicReference .
    """ ;
    rdfs:comment "A reference, usually contained in a footnote or a bibliographic reference list, that refer to another publication, such as a journal article, a book, a book chapter or a Web site. The inclusion of the bibliographic reference in a publication constitutes the performative act of bibliographic citation."@en ;
    rdfs:isDefinedBy deo: ;
    rdfs:subClassOf orb:References,
        deo:Reference ;
    vs:term_status reg:statusStable .

deo:Biography a owl:Class ;
    rdfs:label "biography"@en ;
    vann:example """
    :my-paper 
        dcterms:hasPart :my-biography .

    :my-biography a deo:Biography .
    """ ;
    rdfs:comment "Information describing a person and his or her life history and contributions."@en ;
    rdfs:isDefinedBy deo: ;
    rdfs:subClassOf deo:DiscourseElement ;
    vs:term_status reg:statusStable .

deo:Conclusion a owl:Class ;
    rdfs:label "conclusion" ;
    vann:example """
    :my-paper 
        dcterms:hasPart :my-conclusion .

    :my-conclusion a deo:Conclusion .
    """ ;
    rdfs:comment "A reflection on the preceding text, summarizing the evidence, arguments or premises presented in the document and their logical outcomes. Conclusions are a fundamental feature in academic research publications, and may be included in the Discussion section." ;
    rdfs:isDefinedBy deo: ;
    rdfs:subClassOf deo:DiscourseElement ;
    owl:equivalentClass orb:Conclusion ;
    vs:term_status reg:statusStable .

deo:Contribution a owl:Class ;
    rdfs:label "contribution" ;
    vann:example """
    :my-paper 
        dcterms:hasPart :my-contribution .

    :my-contribution a deo:Contribution .
    """ ;
    rdfs:comment "A description of the part that this publication plays in the overall field." ;
    rdfs:isDefinedBy deo: ;
    rdfs:subClassOf deo:DiscourseElement ;
    owl:equivalentClass sro:Contribution ;
    vs:term_status reg:statusStable .

deo:Data a owl:Class ;
    rdfs:label "data"@en ;
    vann:example """
    :my-paper 
        dcterms:hasPart :my-data .

    :my-data a deo:Data .
    """ ;
    rdfs:comment "A textual description of data used or produced in the work which the document describes, or the data themselves."@en ;
    rdfs:isDefinedBy deo: ;
    rdfs:subClassOf deo:DiscourseElement ;
    vs:term_status reg:statusStable .

deo:DatasetDescription a owl:Class ;
    rdfs:label "dataset description"@en ;
    vann:example """
    :my-paper 
        dcterms:hasPart :my-dataset-description .

    :my-dataset-description a deo:DatasetDescription .
    """ ;
    rdfs:comment "Information describing a dataset held in an external database or repository and including a reference to it, such as a database ID or an accession number."@en ;
    rdfs:isDefinedBy deo: ;
    rdfs:subClassOf deo:ExternalResourceDescription ;
    vs:term_status reg:statusStable .

deo:Dedication a owl:Class ;
    rdfs:label "dedication"@en ;
    vann:example """
    :my-paper 
        dcterms:hasPart :my-dedication .

    :my-dedication a deo:Dedication .
    """ ;
    rdfs:comment "Text in which the author names the person or people for whom he/she has written the document, or to whose memory it is dedicated."@en ;
    rdfs:isDefinedBy deo: ;
    rdfs:subClassOf deo:DiscourseElement ;
    vs:term_status reg:statusStable .

deo:Discussion a owl:Class ;
    rdfs:label "discussion" ;
    vann:example """
    :my-paper 
        dcterms:hasPart :my-discussion .

    :my-discussion a deo:Discussion .
    """ ;
    rdfs:comment "An interpretation and discussion of the results obtained and an analysis of their significance, in support of conclusions. These conclusions may be part of this discussion or may be included in a separate section of the document." ;
    rdfs:isDefinedBy deo: ;
    rdfs:subClassOf deo:DiscourseElement ;
    owl:equivalentClass orb:Discussion ;
    vs:term_status reg:statusStable .

deo:Epilogue a owl:Class ;
    rdfs:label "epilogue"@en ;
    vann:example """
    :my-paper 
        dcterms:hasPart :my-epilogue .

    :my-epilogue a deo:Epilogue .
    """ ;
    rdfs:comment "A piece of writing at the end of a work of literature or drama, usually used to bring closure to the work."@en ;
    rdfs:isDefinedBy deo: ;
    rdfs:subClassOf deo:DiscourseElement ;
    vs:term_status reg:statusStable .

deo:Evaluation a owl:Class ;
    rdfs:label "evaluation" ;
    vann:example """
    :my-paper 
        dcterms:hasPart :my-evaluation .

    :my-evaluation a deo:Evaluation .
    """ ;
    rdfs:comment "A consideration of the value, meaning and significance of the results obtained." ;
    rdfs:isDefinedBy deo: ;
    rdfs:subClassOf deo:DiscourseElement ;
    owl:equivalentClass sro:Evaluation ;
    vs:term_status reg:statusStable .

deo:FutureWork a owl:Class ;
    rdfs:label "future work"@en ;
    vann:example """
    :my-paper 
        dcterms:hasPart :my-future-work .

    :my-future-work a deo:FutureWork .
    """ ;
    rdfs:comment "A proposal for new investigation to be undertaken in order to continue and advance the work described in the publication."@en ;
    rdfs:isDefinedBy deo: ;
    rdfs:subClassOf deo:DiscourseElement ;
    vs:term_status reg:statusStable .

deo:Introduction a owl:Class ;
    rdfs:label "introduction"@en ;
    vann:example """
    :my-paper 
        dcterms:hasPart :my-introduction .

    :my-introduction a deo:Introduction .
    """ ;
    rdfs:comment "An initial description which states the purpose and goals of the following writing, and, in the case of journal articles, typically includes background information on the research topic and a review of related work in the area."@en ;
    rdfs:isDefinedBy deo: ;
    rdfs:subClassOf deo:DiscourseElement ;
    owl:equivalentClass orb:Introduction ;
    vs:term_status reg:statusStable .

deo:Legend a owl:Class ;
    rdfs:label "legend"@en ;
    vann:example """
    :my-paper 
        dcterms:hasPart :my-legend .

    :my-legend a deo:Legend .
    """ ;
    rdfs:comment "Informative text that explicitly explains another item, such as a figure or a table."@en ;
    rdfs:isDefinedBy deo: ;
    rdfs:subClassOf deo:Caption ;
    vs:term_status reg:statusStable .

deo:Materials a owl:Class ;
    rdfs:label "materials"@en ;
    vann:example """
    :my-paper 
        dcterms:hasPart :my-materials .

    :my-materials a deo:Materials .
    """ ;
    rdfs:comment "A description in a research paper documenting the specialized materials used in the work described. This description is often combined with a description of the methods used, in a section entitled 'Methods and Materials', 'Experimental' or a related term."@en ;
    rdfs:isDefinedBy deo: ;
    rdfs:subClassOf deo:DiscourseElement ;
    vs:term_status reg:statusStable .

deo:Methods a owl:Class ;
    rdfs:label "methods"@en ;
    vann:example """
    :my-paper 
        dcterms:hasPart :my-methods .

    :my-methods a deo:Methods .
    """ ;
    rdfs:comment "A description in a research paper documenting the specialized methods used in the work described. This description is often combined with a description of the materials used, in a section entitled 'Methods and Materials', 'Experimental' or a related term."@en ;
    rdfs:isDefinedBy deo: ;
    rdfs:subClassOf deo:DiscourseElement ;
    owl:equivalentClass orb:Methods ;
    vs:term_status reg:statusStable .

deo:Model a owl:Class ;
    rdfs:label "model"@en ;
    vann:example """
    :my-paper 
        dcterms:hasPart :my-model .

    :my-model a deo:Model .
    """ ;
    rdfs:comment "A description of a model used or produced by the work described in the publication."@en ;
    rdfs:isDefinedBy deo: ;
    rdfs:subClassOf deo:DiscourseElement ;
    vs:term_status reg:statusStable .

deo:Motivation a owl:Class ;
    rdfs:label "motivation" ;
    vann:example """
    :my-paper 
        dcterms:hasPart :my-motivation .

    :my-motivation a deo:Motivation .
    """ ;
    rdfs:comment "A description of the justification for undertaking the work described in the publication." ;
    rdfs:isDefinedBy deo: ;
    rdfs:subClassOf deo:DiscourseElement ;
    owl:equivalentClass sro:Motivation ;
    vs:term_status reg:statusStable .

deo:Postscript a owl:Class ;
    rdfs:label "postscript"@en ;
    vann:example """
    :my-paper 
        dcterms:hasPart :my-postscript .

    :my-postscript a deo:Postscript .
    """ ;
    rdfs:comment "Text added after the signature of a letter, or sometimes after the main body of an essay or book."@en ;
    rdfs:isDefinedBy deo: ;
    rdfs:subClassOf deo:DiscourseElement ;
    vs:term_status reg:statusStable .

deo:ProblemStatement a owl:Class ;
    rdfs:label "problem statement"@en ;
    vann:example """
    :my-paper 
        dcterms:hasPart :my-problem-statement .

    :my-problem-statement a deo:ProblemStatement .
    """ ;
    rdfs:comment "A concise description of the issues that needed to be addressed by a work described in the document."@en ;
    rdfs:isDefinedBy deo: ;
    rdfs:subClassOf deo:DiscourseElement ;
    vs:term_status reg:statusStable .

deo:Prologue a owl:Class ;
    rdfs:label "prologue"@en ;
    vann:example """
    :my-paper 
        dcterms:hasPart :my-prologue .

    :my-prologue a deo:Prologue .
    """ ;
    rdfs:comment "A piece of writing at the beginning of a work of literature or drama, usually used to set the scene or to introduce the work."@en ;
    rdfs:isDefinedBy deo: ;
    rdfs:subClassOf deo:DiscourseElement ;
    vs:term_status reg:statusStable .

deo:RelatedWork a owl:Class ;
    rdfs:label "related work"@en ;
    vann:example """
    :my-paper 
        dcterms:hasPart :my-related-work .

    :my-related-work a deo:RelatedWork .
    """ ;
    rdfs:comment "The authors' critical review of current knowledge by specific reference to others' work, both in terms of substantive findings and theoretical and methodological contributions to a particular topic. This description is often included within the introduction section."@en ;
    rdfs:isDefinedBy deo: ;
    rdfs:subClassOf deo:DiscourseElement ;
    vs:term_status reg:statusStable .

deo:Results a owl:Class ;
    rdfs:label "results"@en ;
    vann:example """
    :my-paper 
        dcterms:hasPart :my-results .

    :my-results a deo:Results .
    """ ;
    rdfs:comment "The report of the specific findings of an investigation, given without discussion or conclusion being drawn."@en ;
    rdfs:isDefinedBy deo: ;
    rdfs:subClassOf deo:DiscourseElement ;
    owl:equivalentClass orb:Results ;
    vs:term_status reg:statusStable .

deo:Scenario a owl:Class ;
    rdfs:label "scenario" ;
    vann:example """
    :my-paper 
        dcterms:hasPart :my-scenario .

    :my-scenario a deo:Scenario .
    """ ;
    rdfs:comment "A presentation of a use case or test, based on a real or hypothetical situation, used to help someone think through a complex problem or system." ;
    rdfs:isDefinedBy deo: ;
    rdfs:subClassOf deo:DiscourseElement ;
    owl:equivalentClass sro:Scenario ;
    vs:term_status reg:statusStable .

deo:SupplementaryInformationDescription a owl:Class ;
    rdfs:label "supplementary information description"@en ;
    vann:example """
    :my-paper 
        dcterms:hasPart :my-supplementary-information-description .

    :my-supplementary-information-description a deo:SupplementaryInformationDescription .
    """ ;
    rdfs:comment "Information describing supplementary information relating to the document, including references or links to the relevant supplementary information."@en ;
    rdfs:isDefinedBy deo: ;
    rdfs:subClassOf deo:ExternalResourceDescription ;
    vs:term_status reg:statusStable .

sro:Conclusion a owl:Class ;
    rdfs:label "conclusion"@en ;
    rdfs:comment "Conclusive overview of the publication."@en ;
    rdfs:isDefinedBy sro: .

sro:Discussion a owl:Class ;
    rdfs:label "discussion"@en ;
    rdfs:comment "Interesting issues discovered while researching the publication's topic."@en ;
    rdfs:isDefinedBy sro: .

rdfs:comment a owl:AnnotationProperty .

rdfs:label a owl:AnnotationProperty .

dcterms:hasPart a owl:ObjectProperty,
        owl:TransitiveProperty ;
    rdfs:label "has part"@en ;
    vann:example """
    :my-paper 
        dcterms:hasPart :my-acknowledgements .

    :my-acknowledgements a deo:Acknowledgements .
    """ ;
    rdfs:comment "A related resource that is included either physically or logically in the described resource."@en ;
    rdfs:isDefinedBy dcterms: ;
    rdfs:subPropertyOf dcterms:relation ;
    owl:inverseOf dcterms:isPartOf ;
    vs:term_status reg:statusStable .

dcterms:isPartOf a owl:ObjectProperty,
        owl:TransitiveProperty ;
    rdfs:label "is part of"@en ;
    vann:example """
    :my-acknowledgements a deo:Acknowledgements ;
        dcterms:isPartOf :my-paper .
    """ ;
    rdfs:comment "A related resource in which the described resource is physically or logically included."@en ;
    rdfs:isDefinedBy dcterms: ;
    rdfs:subPropertyOf dcterms:relation ;
    vs:term_status reg:statusStable .

orb:Conclusion a owl:Class ;
    rdfs:label "conclusion"@en ;
    rdfs:comment "A reflection on and summarization of the publication."@en ;
    rdfs:isDefinedBy orb: .

orb:Discussion a owl:Class ;
    rdfs:label "discussion"@en ;
    rdfs:comment "Interesting issues discovered while researching the publication's topic."@en ;
    rdfs:isDefinedBy orb: .

orb:Introduction a owl:Class ;
    rdfs:label "introduction"@en ;
    rdfs:comment "An introduction explaining the general scope and purpose of the study illustrated in the publication."@en ;
    rdfs:isDefinedBy orb: .

orb:Methods a owl:Class ;
    rdfs:label "methods"@en ;
    rdfs:comment "A description of the methods used to carry out the study illustrated in the publication."@en ;
    rdfs:isDefinedBy orb: .

orb:References a owl:Class ;
    rdfs:label "references"@en ;
    rdfs:comment "A list of references used as sources for the study illustrated in the publication."@en ;
    rdfs:isDefinedBy orb: .

orb:Results a owl:Class ;
    rdfs:label "results"@en ;
    rdfs:comment "A description of the results obtained after carrying out the study illustrated in the publication."@en ;
    rdfs:isDefinedBy orb: .

deo:Caption a owl:Class ;
    rdfs:label "caption"@en ;
    vann:example """
    :my-paper 
        dcterms:hasPart :my-caption .

    :my-caption a deo:Caption .
    """ ;
    rdfs:comment "Text accompanying another item, such as a picture."@en ;
    rdfs:isDefinedBy deo: ;
    rdfs:subClassOf deo:DiscourseElement ;
    vs:term_status reg:statusStable .

sro:Background a owl:Class ;
    rdfs:label "background"@en ;
    rdfs:comment "Builds a view over the related work and foundational theories in the field."@en ;
    rdfs:isDefinedBy sro: .

sro:Contribution a owl:Class ;
    rdfs:label "contribution"@en ;
    rdfs:comment "The solution proposed by the publication."@en ;
    rdfs:isDefinedBy sro: .

sro:Evaluation a owl:Class ;
    rdfs:label "evaluation"@en ;
    rdfs:comment "The evaluation methodology and its associated results."@en ;
    rdfs:isDefinedBy sro: .

sro:Motivation a owl:Class ;
    rdfs:label "motivation"@en ;
    rdfs:comment "The reason motivating the research presented in the paper."@en ;
    rdfs:isDefinedBy sro: .

sro:Scenario a owl:Class ;
    rdfs:label "scenario"@en ;
    rdfs:comment "Real-world use cases in which the solution provided by the publication is applicable."@en ;
    rdfs:isDefinedBy sro: .

dcterms:relation a owl:ObjectProperty,
        owl:SymmetricProperty ;
    rdfs:label "has relation"@en ;
    rdfs:comment "A related resource."@en ;
    rdfs:isDefinedBy dcterms: .

deo:ExternalResourceDescription a owl:Class ;
    rdfs:label "external resource description"@en ;
    vann:example """
    :my-paper 
        dcterms:hasPart :my-external-resource-description .

    :my-external-resource-description a deo:ExternalResourceDescription ;
        dcterms:hasPart :my-reference .

    :my-reference a deo:Reference .
    """ ;
    rdfs:comment "Information describing an external resource and including a reference to that resource."@en ;
    rdfs:isDefinedBy deo: ;
    rdfs:subClassOf [ a owl:Class ;
            owl:intersectionOf ( deo:DiscourseElement [ a owl:Restriction ;
                        owl:onProperty dcterms:hasPart ;
                        owl:someValuesFrom deo:Reference ] ) ] ;
    vs:term_status reg:statusStable .

deo:Reference a owl:Class ;
    rdfs:label "reference"@en ;
    vann:example """
    :my-paper 
        dcterms:hasPart :my-reference .

    :my-reference a deo:Reference .
    """ ;
    rdfs:comment "A reference to a specific part of the document, or to another publication."@en ;
    rdfs:isDefinedBy deo: ;
    rdfs:subClassOf deo:DiscourseElement ;
    vs:term_status reg:statusStable .

deo:DiscourseElement a owl:Class ;
    rdfs:label "discourse element"@en ;
    vann:example """
    :my-paper 
        dcterms:hasPart :my-discourse-element .

    :my-discourse-element a deo:DiscourseElement .
    """ ;
    rdfs:comment "An element of a document that carries out a rhetorical function."@en ;
    rdfs:isDefinedBy deo: ;
    rdfs:subClassOf owl:Thing ;
    vs:term_status reg:statusStable .

